Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Partial Service Interruption
Incident Report for Smartsheet EU
Postmortem

Between 4:10 pm and 5:00 pm Pacific Time, customers had intermittent issues using sharing, mobile app, Admin Center, Conversations, Event Reporting, Activity Log, and Workflows in Smartsheet EU. We traced the issue to a planned ongoing server maintenance activity which unexpectedly caused this secondary impact. We paused the maintenance activity which helped with the recovery. The maintenance will be planned at a different time to avoid customer impact.

Posted Oct 28, 2021 - 02:06 UTC

Resolved
This incident has been resolved.
Posted Oct 28, 2021 - 02:05 UTC
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of the application.
Posted Oct 28, 2021 - 00:05 UTC
Investigating
We are investigating intermittent issues with Smartsheet and will provide an update within the next 30 minutes.
Posted Oct 27, 2021 - 23:55 UTC
This incident affected: Core Application (Sheets, Sharing) and Administration and Audit (Admin Center).