Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Degraded performance in multiple services

Incident Report for Smartsheet EU

Resolved

This issue affected our Smartsheet US instance.

Please refer to our Smartsheet US status page for updates/timeline: https://status.smartsheet.com/
Posted Oct 20, 2025 - 12:14 UTC

Update

We continue to see recovery in our services and are working to ensure stability and resolution.
Posted Oct 20, 2025 - 11:13 UTC

Monitoring

We experienced an issue with the Smartsheet application today.

We're seeing recovery in our services and are working to ensure stability and resolution.
Posted Oct 20, 2025 - 10:49 UTC
This incident affected: Core Application (Smartsheet Login, Single Sign On ( Company Credentials ), Sheets, Forms, Reports, Dashboards), Documents (Attachments, Document Builder, Document Proofing), Notifications (Email Notifications, In App Notifications, Messaging App Notifications, Conversations), Workflows (In App Workflows, Bridge by Smartsheet, Sharing), Administration and Audit (Admin Center, Event Reporting API, User and Group Management, Payments & Licensing, Activity Log), Developers and API (REST API, Webhooks, API Access Tokens), Help and Community (Smartsheet Website, Help Center, Community, Marketplace and Solutions Center, In-App Chat), Apps (Mobile App), Connectors (Data Shuttle, Jira Connector, Salesforce Connector, Tableau Connector), Digital Asset Management (Brandfolder) (Smartsheet Brandfolder Integration), Advance Capabilities (Control Center, Dynamic View, WorkApps, Calendar, Pivot, Datamesh, DataTable), AI Tools, Resource Management, Third Party Integrations, and Third Party Sign In (Sign in via Google, Sign in via Microsoft Azure AD, Sign in via Apple ID).